What’s Vulnerable › Vulnerabilities
CVE-2022-31064: Cross site scripting in username that will trigger by sending chat
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
BigBlueButton is an open source web conferencing system. Users in meetings with private chat enabled are vulnerable to a cross site scripting attack in affected versions. The attack occurs when the attacker (with xss in the name) starts a chat. in the victim's client the JavaScript will be executed. This issue has been addressed in version 2.4.8 and 2.5.0. There are no known workarounds for this issue.
Affected products
- bigbluebutton: from 2.4 before 2.4.8; 2.3.0, 2.4.9, 2.5-alpha1, 2.5-alpha2, 2.5-alpha3, 2.5-alpha4 (+8) — fixed in 2.4.8
How to fix
Upgrade to a fixed version: bigbluebutton 2.4.8. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/167682/BigBlueButton-2.3-2.4.7-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2022/Jun/52
- https://github.com/bigbluebutton/bigbluebutton/pull/15067
- https://github.com/bigbluebutton/bigbluebutton/pull/15090
- https://github.com/bigbluebutton/bigbluebutton/security/advisories/GHSA-hwv2-5pf5-hr87
- https://pentests.nl/pentest-blog/stored-xss-in-bigbluebutton/
- http://packetstormsecurity.com/files/167682/BigBlueButton-2.3-2.4.7-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2022/Jun/52
- https://github.com/bigbluebutton/bigbluebutton/pull/15067
- https://github.com/bigbluebutton/bigbluebutton/pull/15090
- https://github.com/bigbluebutton/bigbluebutton/security/advisories/GHSA-hwv2-5pf5-hr87
- https://pentests.nl/pentest-blog/stored-xss-in-bigbluebutton/
Get alerted when CVE-2022-31064 or the next vulnerability affects your stack