What’s Vulnerable › Vulnerabilities
CVE-2022-31069: Potential Authorization Header Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-15 · updated 2026-06-17
- Weakness: CWE-200
Description
NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to control when Authorization headers should should be forwarded for specific backend services configured by the application developer. This could have resulted in sensitive information such as OAuth bearer access tokens being inadvertently exposed to such services that should not see them. A new feature has been introduced in the patched version of nestjs-proxy that allows application developers to opt out of forwarding the Authorization headers on a per service basis using the `forwardToken` config setting. Developers are advised to review the README for this library on Github or NPM for further details on how this configuration can be applied. This issue has been fixed in version 0.7.0 of `@finastra/nestjs-proxy`. Users of `@ffdc/nestjs-proxy` are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use `@finastra/nestjs-proxy` instead.
Affected products
- Finastra Nestjs-Proxy: before 0.7.0 — fixed in 0.7.0
- Nestjs-Proxy Project Nestjs-Proxy: through 0.4.0
How to fix
Upgrade to a fixed version: Finastra Nestjs-Proxy 0.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/Finastra/finastra-nodejs-libs/pull/231
- https://github.com/Finastra/finastra-nodejs-libs/security/advisories/GHSA-j562-c3cw-3p5g
- https://github.com/Finastra/finastra-nodejs-libs/pull/231
- https://github.com/Finastra/finastra-nodejs-libs/security/advisories/GHSA-j562-c3cw-3p5g
Get alerted when CVE-2022-31069 or the next vulnerability affects your stack