What’s Vulnerable › Vulnerabilities
CVE-2022-31073: KubeEdge Edge ServiceBus module DoS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-400
Description
KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. Prior to versions 1.11.1, 1.10.2, and 1.9.4, the ServiceBus server on the edge side may be susceptible to a DoS attack if an HTTP request containing a very large Body is sent to it. It is possible for the node to be exhausted of memory. The consequence of the exhaustion is that other services on the node, e.g. other containers, will be unable to allocate memory and thus causing a denial of service. Malicious apps accidentally pulled by users on the host and have the access to send HTTP requests to localhost may make an attack. It will be affected only when users enable the `ServiceBus` module in the config file `edgecore.yaml`. This bug has been fixed in Kubeedge 1.11.1, 1.10.2, and 1.9.4. As a workaround, disable the `ServiceBus` module in the config file `edgecore.yaml`.
Affected products
- kubeedge: before 1.9.4; from 1.10.0 before 1.10.2; from 1.11.0 before 1.11.1 — fixed in 1.10.2, 1.11.1, 1.9.4
How to fix
Upgrade to a fixed version: kubeedge 1.10.2, 1.11.1, 1.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/kubeedge/kubeedge/pull/4038
- https://github.com/kubeedge/kubeedge/pull/4039
- https://github.com/kubeedge/kubeedge/pull/4042
- https://github.com/kubeedge/kubeedge/security/advisories/GHSA-vwm6-qc77-v2rh
- https://github.com/kubeedge/kubeedge/pull/4038
- https://github.com/kubeedge/kubeedge/pull/4039
- https://github.com/kubeedge/kubeedge/pull/4042
- https://github.com/kubeedge/kubeedge/security/advisories/GHSA-vwm6-qc77-v2rh
Get alerted when CVE-2022-31073 or the next vulnerability affects your stack