What’s Vulnerable › Vulnerabilities
CVE-2022-31076: Malicious Message can crash CloudCore in KubeEdge
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-476
Description
KubeEdge is built upon Kubernetes and extends native containerized application orchestration and device management to hosts at the Edge. In affected versions a malicious message can crash CloudCore by triggering a nil-pointer dereference in the UDS Server. Since the UDS Server only communicates with the CSI Driver on the cloud side, the attack is limited to the local host network. As such, an attacker would already need to be an authenticated user of the Cloud. Additionally it will be affected only when users turn on the unixsocket switch in the config file cloudcore.yaml. This bug has been fixed in Kubeedge 1.11.0, 1.10.1, and 1.9.3. Users should update to these versions to resolve the issue. Users unable to upgrade should sisable the unixsocket switch of CloudHub in the config file cloudcore.yaml.
Affected products
- kubeedge: before 1.9.3; 1.10.0, 1.10.0-beta0 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: kubeedge 1.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/kubeedge/kubeedge/pull/3899/commits/5d60ae9eabd6b6b7afe38758e19bbe8137664701
- https://github.com/kubeedge/kubeedge/security/advisories/GHSA-8f4f-v9x5-cg6j
- https://github.com/kubeedge/kubeedge/pull/3899/commits/5d60ae9eabd6b6b7afe38758e19bbe8137664701
- https://github.com/kubeedge/kubeedge/security/advisories/GHSA-8f4f-v9x5-cg6j
Get alerted when CVE-2022-31076 or the next vulnerability affects your stack