What’s Vulnerable › Vulnerabilities
CVE-2022-31087: Incorrect Default Permissions in ldap-account-manager
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-74
Description
LDAP Account Manager (LAM) is a webfrontend for managing entries (e.g. users, groups, DHCP settings) stored in an LDAP directory. In versions prior to 8.0 the tmp directory, which is accessible by /lam/tmp/, allows interpretation of .php (and .php5/.php4/.phpt/etc) files. An attacker capable of writing files under www-data privileges can write a web-shell into this directory, and gain a Code Execution on the host. This issue has been fixed in version 8.0. Users unable to upgrade should disallow executing PHP scripts in (/var/lib/ldap-account-manager/)tmp directory.
Affected products
- Debian Linux: 11.0
- ldap-account-manager Ldap Account Manager: before 8.0 — fixed in 8.0
How to fix
Upgrade to a fixed version: ldap-account-manager Ldap Account Manager 8.0. Check the vendor advisory for mitigations.
References
- https://github.com/LDAPAccountManager/lam/commit/f1d5d04952f39a1b4ea203d3964fa88e1429dfd4
- https://github.com/LDAPAccountManager/lam/security/advisories/GHSA-q8g5-45m4-q95p
- https://www.debian.org/security/2022/dsa-5177
- https://github.com/LDAPAccountManager/lam/commit/f1d5d04952f39a1b4ea203d3964fa88e1429dfd4
- https://github.com/LDAPAccountManager/lam/security/advisories/GHSA-q8g5-45m4-q95p
- https://www.debian.org/security/2022/dsa-5177
Get alerted when CVE-2022-31087 or the next vulnerability affects your stack