What’s Vulnerable › Vulnerabilities
CVE-2022-31089: Invalid file request can crashe parse-server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-252
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In affected versions certain types of invalid files requests are not handled properly and can crash the server. If you are running multiple Parse Server instances in a cluster, the availability impact may be low; if you are running Parse Server as single instance without redundancy, the availability impact may be high. This issue has been addressed in versions 4.10.12 and 5.2.3. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- parse-community parse-server: before 4.10.12; from 5.0.0 before 5.2.3 — fixed in 4.10.12, 5.2.3
How to fix
Upgrade to a fixed version: parse-community parse-server 4.10.12, 5.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/5be375dec2fa35425c1003ae81c55995ac72af92
- https://github.com/parse-community/parse-server/security/advisories/GHSA-xw6g-jjvf-wwf9
- https://github.com/parse-community/parse-server/commit/5be375dec2fa35425c1003ae81c55995ac72af92
- https://github.com/parse-community/parse-server/security/advisories/GHSA-xw6g-jjvf-wwf9
Get alerted when CVE-2022-31089 or the next vulnerability affects your stack