What’s Vulnerable › Vulnerabilities
CVE-2022-31090: CURLOPT_HTTPAUTH option not cleared on change of origin in Guzzle
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-200
Description
Guzzle, an extensible PHP HTTP client. `Authorization` headers on requests are sensitive information. In affected versions when using our Curl handler, it is possible to use the `CURLOPT_HTTPAUTH` option to specify an `Authorization` header. On making a request which responds with a redirect to a URI with a different origin (change in host, scheme or port), if we choose to follow it, we should remove the `CURLOPT_HTTPAUTH` option before continuing, stopping curl from appending the `Authorization` header to the new request. Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Note that a partial fix was implemented in Guzzle 7.4.2, where a change in host would trigger removal of the curl-added Authorization header, however this earlier fix did not cover change in scheme or change in port. If you do not require or expect redirects to be followed, one should simply disable redirects all together. Alternatively, one can specify to use the Guzzle steam handler backend, rather than curl.
Affected products
- Debian Linux: 11.0
- guzzle: before 6.5.8; from 7.0.0 before 7.4.5 — fixed in 6.5.8, 7.4.5
- Packagist Guzzlehttp/Guzzle: before 6.5.8; from 7.0.0 before 7.4.5; 4.0.0, 4.0.0-rc.1, 4.0.0-rc.2, 4.0.1, 4.0.2, 4.1.0 (+126) — fixed in 6.5.8, 7.4.5
How to fix
Upgrade to a fixed version: guzzle 6.5.8, 7.4.5; Packagist Guzzlehttp/Guzzle 6.5.8, 7.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/guzzle/guzzle/commit/1dd98b0564cb3f6bd16ce683cb755f94c10fbd82
- https://github.com/guzzle/guzzle/security/advisories/GHSA-25mq-v84q-4j7r
- https://security.gentoo.org/glsa/202305-24
- https://www.debian.org/security/2022/dsa-5246
- https://github.com/guzzle/guzzle/commit/1dd98b0564cb3f6bd16ce683cb755f94c10fbd82
- https://github.com/guzzle/guzzle/security/advisories/GHSA-25mq-v84q-4j7r
- https://security.gentoo.org/glsa/202305-24
- https://www.debian.org/security/2022/dsa-5246
Get alerted when CVE-2022-31090 or the next vulnerability affects your stack