What’s Vulnerable › Vulnerabilities
CVE-2022-31095: Exposure of Sensitive Information in discourse-chat
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-21 · updated 2026-06-17
- Weakness: CWE-200
Description
discourse-chat is a chat plugin for the Discourse application. Versions prior to 0.4 are vulnerable to an exposure of sensitive information, where an attacker who knows the message ID for a channel they do not have access to can view that message using the chat message lookup endpoint, primarily affecting direct message channels. There are no known workarounds for this issue, and users are advised to update the plugin.
Affected products
- discourse-chat: before 0.4 — fixed in 0.4
How to fix
Upgrade to a fixed version: discourse-chat 0.4. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse-chat/security/advisories/GHSA-r979-jhp2-3f6h
- https://github.com/discourse/discourse-chat/security/advisories/GHSA-r979-jhp2-3f6h
Get alerted when CVE-2022-31095 or the next vulnerability affects your stack