What’s Vulnerable › Vulnerabilities

CVE-2022-31097: Stored XSS in Grafana's Unified Alerting

Description

Grafana is an open-source platform for monitoring and observability. Versions on the 8.x and 9.x branch prior to 9.0.3, 8.5.9, 8.4.10, and 8.3.10 are vulnerable to stored cross-site scripting via the Unified Alerting feature of Grafana. An attacker can exploit this vulnerability to escalate privilege from editor to admin by tricking an authenticated admin to click on a link. Versions 9.0.3, 8.5.9, 8.4.10, and 8.3.10 contain a patch. As a workaround, it is possible to disable alerting or use legacy alerting.

Affected products

How to fix

Upgrade to a fixed version: Grafana 8.3.10, 8.4.10, 8.5.9, 9.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-31097 or the next vulnerability affects your stack