What’s Vulnerable › Vulnerabilities
CVE-2022-31099: Uncontrolled Recursion in rulex
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-674
Description
rulex is a new, portable, regular expression language. When parsing untrusted rulex expressions, the stack may overflow, possibly enabling a Denial of Service attack. This happens when parsing an expression with several hundred levels of nesting, causing the process to abort immediately. This is a security concern for you, if your service parses untrusted rulex expressions (expressions provided by an untrusted user), and your service becomes unavailable when the process running rulex aborts due to a stack overflow. The crash is fixed in version **0.4.3**. Affected users are advised to update to this version. There are no known workarounds for this issue.
Affected products
- Pomsky-Lang Pomsky: before 0.4.3 — fixed in 0.4.3
How to fix
Upgrade to a fixed version: Pomsky-Lang Pomsky 0.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/rulex-rs/rulex/commit/60aa2dc03a22d69c8800fec81f99c96958a11363
- https://github.com/rulex-rs/rulex/security/advisories/GHSA-v78m-2q7v-fjqp
- https://github.com/rulex-rs/rulex/commit/60aa2dc03a22d69c8800fec81f99c96958a11363
- https://github.com/rulex-rs/rulex/security/advisories/GHSA-v78m-2q7v-fjqp
Get alerted when CVE-2022-31099 or the next vulnerability affects your stack