What’s Vulnerable › Vulnerabilities
CVE-2022-31103: Improper handling of CSS at-rules in lettersanitizer
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-754
Description
lettersanitizer is a DOM-based HTML email sanitizer for in-browser email rendering. All versions of lettersanitizer below 1.0.2 are affected by a denial of service issue when processing a CSS at-rule `@keyframes`. This package is depended on by [react-letter](https://github.com/mat-sz/react-letter), therefore everyone using react-letter is also at risk. The problem has been patched in version 1.0.2.
Affected products
- mat-sz lettersanitizer: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: mat-sz lettersanitizer 1.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/mat-sz/lettersanitizer/commit/96d3dfe2ef0465d47324ed4d13e91ba0816a173f
- https://github.com/mat-sz/lettersanitizer/security/advisories/GHSA-7r3r-gq8p-v9jj
- https://github.com/mat-sz/react-letter/issues/17
- https://github.com/mat-sz/lettersanitizer/commit/96d3dfe2ef0465d47324ed4d13e91ba0816a173f
- https://github.com/mat-sz/lettersanitizer/security/advisories/GHSA-7r3r-gq8p-v9jj
- https://github.com/mat-sz/react-letter/issues/17
Get alerted when CVE-2022-31103 or the next vulnerability affects your stack