What’s Vulnerable › Vulnerabilities
CVE-2022-31105: Argo CD's certificate verification is skipped for connections to OIDC providers
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-12 · updated 2026-06-17
- Weakness: CWE-295
Description
Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Argo CD starting with version 0.4.0 and prior to 2.2.11, 2.3.6, and 2.4.5 is vulnerable to an improper certificate validation bug which could cause Argo CD to trust a malicious (or otherwise untrustworthy) OpenID Connect (OIDC) provider. A patch for this vulnerability has been released in Argo CD versions 2.4.5, 2.3.6, and 2.2.11. There are no complete workarounds, but a partial workaround is available. Those who use an external OIDC provider (not the bundled Dex instance), can mitigate the issue by setting the `oidc.config.rootCA` field in the `argocd-cm` ConfigMap. This mitigation only forces certificate validation when the API server handles login flows. It does not force certificate verification when verifying tokens on API calls.
Affected products
- argoproj argo-cd: from 2.3.0 before 2.3.6; from 2.4.0 before 2.4.5 — fixed in 2.3.6, 2.4.5
- Linuxfoundation Argo-Cd: from 0.4.0 before 2.2.11 — fixed in 2.2.11
How to fix
Upgrade to a fixed version: argoproj argo-cd 2.3.6, 2.4.5; Linuxfoundation Argo-Cd 2.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/argoproj/argo-cd/releases/tag/v2.3.6
- https://github.com/argoproj/argo-cd/releases/tag/v2.4.5
- https://github.com/argoproj/argo-cd/security/advisories/GHSA-7943-82jg-wmw5
- https://github.com/argoproj/argo-cd/releases/tag/v2.3.6
- https://github.com/argoproj/argo-cd/releases/tag/v2.4.5
- https://github.com/argoproj/argo-cd/security/advisories/GHSA-7943-82jg-wmw5
Get alerted when CVE-2022-31105 or the next vulnerability affects your stack