What’s Vulnerable › Vulnerabilities
CVE-2022-31106: Prototype Pollution in underscore.deep
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-28 · updated 2026-06-17
- Weakness: CWE-915
Description
Underscore.deep is a collection of Underscore mixins that operate on nested objects. Versions of `underscore.deep` prior to version 0.5.3 are vulnerable to a prototype pollution vulnerability. An attacker can craft a malicious payload and pass it to `deepFromFlat`, which would pollute any future Objects created. Any users that have `deepFromFlat` or `deepPick` (due to its dependency on `deepFromFlat`) in their code should upgrade to version 0.5.3 as soon as possible. Users unable to upgrade may mitigate this issue by modifying `deepFromFlat` to prevent specific keywords which will prevent this from happening.
Affected products
- Clever underscore.deep: before 0.5.3 — fixed in 0.5.3
How to fix
Upgrade to a fixed version: Clever underscore.deep 0.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/Clever/underscore.deep/commit/b5e109ad05b48371be225fa4d490dd08a94e8ef7
- https://github.com/Clever/underscore.deep/security/advisories/GHSA-8j79-hfj5-f2xm
- https://github.com/Clever/underscore.deep/commit/b5e109ad05b48371be225fa4d490dd08a94e8ef7
- https://github.com/Clever/underscore.deep/security/advisories/GHSA-8j79-hfj5-f2xm
Get alerted when CVE-2022-31106 or the next vulnerability affects your stack