What’s Vulnerable › Vulnerabilities
CVE-2022-31112: Protected fields exposed via LiveQuery in parse-server
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-30 · updated 2026-06-17
- Weakness: CWE-200
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In affected versions parse Server LiveQuery does not remove protected fields in classes, passing them to the client. The LiveQueryController now removes protected fields from the client response. Users are advised to upgrade. Users unable t upgrade should use `Parse.Cloud.afterLiveQueryEvent` to manually remove protected fields.
Affected products
- parse-community parse-server: before 4.10.13; from 5.0.0 before 5.2.4 — fixed in 4.10.13, 5.2.4
How to fix
Upgrade to a fixed version: parse-community parse-server 4.10.13, 5.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/309f64ced8700321df056fb3cc97f15007a00df1
- https://github.com/parse-community/parse-server/commit/9fd4516cde5c742f9f29dd05468b4a43a85639a6
- https://github.com/parse-community/parse-server/issues/8073
- https://github.com/parse-community/parse-server/pull/8074
- https://github.com/parse-community/parse-server/releases/tag/5.2.4
- https://github.com/parse-community/parse-server/security/advisories/GHSA-crrq-vr9j-fxxh
- https://github.com/parse-community/parse-server/commit/309f64ced8700321df056fb3cc97f15007a00df1
- https://github.com/parse-community/parse-server/commit/9fd4516cde5c742f9f29dd05468b4a43a85639a6
- https://github.com/parse-community/parse-server/issues/8073
- https://github.com/parse-community/parse-server/pull/8074
- https://github.com/parse-community/parse-server/releases/tag/5.2.4
- https://github.com/parse-community/parse-server/security/advisories/GHSA-crrq-vr9j-fxxh
Get alerted when CVE-2022-31112 or the next vulnerability affects your stack