What’s Vulnerable › Vulnerabilities
CVE-2022-31115: Unsafe YAML deserialization in opensearch-ruby
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-30 · updated 2026-06-17
- Weakness: CWE-502
Description
opensearch-ruby is a community-driven, open source fork of elasticsearch-ruby. In versions prior to 2.0.1 the ruby `YAML.load` function was used instead of `YAML.safe_load`. As a result opensearch-ruby 2.0.0 and prior can lead to unsafe deserialization using YAML.load if the response is of type YAML. An attacker must be in control of an opensearch server and convince the victim to connect to it in order to exploit this vulnerability. The problem has been patched in opensearch-ruby gem version 2.0.1. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- AWS Opensearch: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: AWS Opensearch 2.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/opensearch-project/opensearch-ruby/pull/77
- https://github.com/opensearch-project/opensearch-ruby/security/advisories/GHSA-977c-63xq-cgw3
- https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated/
- https://github.com/opensearch-project/opensearch-ruby/pull/77
- https://github.com/opensearch-project/opensearch-ruby/security/advisories/GHSA-977c-63xq-cgw3
- https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated/
Get alerted when CVE-2022-31115 or the next vulnerability affects your stack