What’s Vulnerable › Vulnerabilities
CVE-2022-31121: Improper Input Validation in fabric hyperledger
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-07 · updated 2026-06-17
- Weakness: CWE-20
Description
Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commit 0f1835949 which checks for missing consensus messages and returns an error to the consensus client should the message be missing. Users are advised to upgrade to versions 2.2.7 or v2.4.5. There are no known workarounds for this issue.
Affected products
- hyperledger fabric: before 2.2.7; from 2.3.0 before 2.4.5 — fixed in 2.2.7, 2.4.5
How to fix
Upgrade to a fixed version: hyperledger fabric 2.2.7, 2.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/hyperledger/fabric/commit/0f18359493bcbd5f9f9d1a9b05adabfe5da23b06
- https://github.com/hyperledger/fabric/releases/tag/v2.2.7
- https://github.com/hyperledger/fabric/releases/tag/v2.4.5
- https://github.com/hyperledger/fabric/security/advisories/GHSA-72x4-cq6r-jp4p
- https://github.com/hyperledger/fabric/commit/0f18359493bcbd5f9f9d1a9b05adabfe5da23b06
- https://github.com/hyperledger/fabric/releases/tag/v2.2.7
- https://github.com/hyperledger/fabric/releases/tag/v2.4.5
- https://github.com/hyperledger/fabric/security/advisories/GHSA-72x4-cq6r-jp4p
Get alerted when CVE-2022-31121 or the next vulnerability affects your stack