What’s Vulnerable › Vulnerabilities
CVE-2022-31124: Possible leak of key's raw field if declared length is incorrect in openssh_key_parser
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-06 · updated 2026-06-17
- Weakness: CWE-209
Description
openssh_key_parser is an open source Python package providing utilities to parse and pack OpenSSH private and public key files. In versions prior to 0.0.6 if a field of a key is shorter than it is declared to be, the parser raises an error with a message containing the raw field value. An attacker able to modify the declared length of a key's sensitive field can thus expose the raw value of that field. Users are advised to upgrade to version 0.0.6, which no longer includes the raw field value in the error message. There are no known workarounds for this issue.
Affected products
- scottcwang openssh_key_parser: before 0.0.6 — fixed in 0.0.6
How to fix
Upgrade to a fixed version: scottcwang openssh_key_parser 0.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/scottcwang/openssh_key_parser/commit/26e0a471e9fdb23e635bc3014cf4cbd2323a08d3
- https://github.com/scottcwang/openssh_key_parser/commit/274447f91b4037b7050ae634879b657554523b39
- https://github.com/scottcwang/openssh_key_parser/commit/d5b53b4b7e76c5b666fc657019dbf864fb04076c
- https://github.com/scottcwang/openssh_key_parser/pull/5
- https://github.com/scottcwang/openssh_key_parser/security/advisories/GHSA-hm37-9xh2-q499
- https://github.com/scottcwang/openssh_key_parser/commit/26e0a471e9fdb23e635bc3014cf4cbd2323a08d3
- https://github.com/scottcwang/openssh_key_parser/commit/274447f91b4037b7050ae634879b657554523b39
- https://github.com/scottcwang/openssh_key_parser/commit/d5b53b4b7e76c5b666fc657019dbf864fb04076c
- https://github.com/scottcwang/openssh_key_parser/pull/5
- https://github.com/scottcwang/openssh_key_parser/security/advisories/GHSA-hm37-9xh2-q499
Get alerted when CVE-2022-31124 or the next vulnerability affects your stack