What’s Vulnerable › Vulnerabilities
CVE-2022-31132: Unauthenticated SSRF in 3rd party module "cerdic/csstidy"
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-04 · updated 2026-06-17
- Weakness: CWE-918
Description
Nextcloud Mail is an email application for the nextcloud personal cloud product. Affected versions shipped with a CSS minifier on the path `./vendor/cerdic/css-tidy/css_optimiser.php`. Access to the minifier is unrestricted and access may lead to Server-Side Request Forgery (SSRF). It is recommendet to upgrade to Mail 1.12.7 or Mail 1.13.6. Users unable to upgrade may manually delete the file located at `./vendor/cerdic/css-tidy/css_optimiser.php`
Affected products
- nextcloud Mail: before 1.12.8; from 1.13.0 before 1.13.6 — fixed in 1.12.8, 1.13.6
How to fix
Upgrade to a fixed version: nextcloud Mail 1.12.8, 1.13.6. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-24pm-rjfv-23mh
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-24pm-rjfv-23mh
Get alerted when CVE-2022-31132 or the next vulnerability affects your stack