What’s Vulnerable › Vulnerabilities
CVE-2022-31137: Unauthenticated Remote Code Execution in Roxy-WI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 90.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-08 · updated 2026-06-17
- Weakness: CWE-78
Description
Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Versions prior to 6.1.1.0 are subject to a remote code execution vulnerability. System commands can be run remotely via the subprocess_execute function without processing the inputs received from the user in the /app/options.py file. Attackers need not be authenticated to exploit this vulnerability. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- roxy-wi: before 6.1.1.0 — fixed in 6.1.1.0
How to fix
Upgrade to a fixed version: roxy-wi 6.1.1.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/167805/Roxy-WI-Remote-Command-Execution.html
- http://packetstormsecurity.com/files/171648/Roxy-WI-6.1.0.0-Improper-Authentication-Control.html
- http://packetstormsecurity.com/files/171652/Roxy-WI-6.1.1.0-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/172547/Roxy-WI-6.1.0.0-Remote-Command-Execution.html
- https://github.com/hap-wi/roxy-wi/commit/82666df1e60c45dd6aa533b01a392f015d32f755
- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-53r2-mq99-f532
- http://packetstormsecurity.com/files/167805/Roxy-WI-Remote-Command-Execution.html
- http://packetstormsecurity.com/files/171648/Roxy-WI-6.1.0.0-Improper-Authentication-Control.html
- http://packetstormsecurity.com/files/171652/Roxy-WI-6.1.1.0-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/172547/Roxy-WI-6.1.0.0-Remote-Command-Execution.html
- https://github.com/hap-wi/roxy-wi/commit/82666df1e60c45dd6aa533b01a392f015d32f755
- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-53r2-mq99-f532
Get alerted when CVE-2022-31137 or the next vulnerability affects your stack