What’s Vulnerable › Vulnerabilities
CVE-2022-31140: Valinor error messages leading to potential data exfiltration
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-209
Description
Valinor is a PHP library that helps to map any input into a strongly-typed value object structure. Prior to version 0.12.0, Valinor can use `Throwable#getMessage()` when it should not have permission to do so. This is a problem with cases such as an SQL exception showing an SQL snippet, a database connection exception showing database IP address/username/password, or a timeout detail / out of memory detail. Attackers could use this information for potential data exfiltration, denial of service attacks, enumeration attacks, etc. Version 0.12.0 contains a patch for this vulnerability.
Affected products
- CuyZ Valinor: before 0.12.0 — fixed in 0.12.0
How to fix
Upgrade to a fixed version: CuyZ Valinor 0.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/CuyZ/Valinor/releases/tag/0.12.0
- https://github.com/CuyZ/Valinor/security/advisories/GHSA-5pgm-3j3g-2rc7
- https://github.com/CuyZ/Valinor/releases/tag/0.12.0
- https://github.com/CuyZ/Valinor/security/advisories/GHSA-5pgm-3j3g-2rc7
Get alerted when CVE-2022-31140 or the next vulnerability affects your stack