What’s Vulnerable › Vulnerabilities

CVE-2022-31142: Potential Timing Attack Vector in @fastify/bearer-auth

Description

@fastify/bearer-auth is a Fastify plugin to require bearer Authorization headers. @fastify/bearer-auth prior to versions 7.0.2 and 8.0.1 does not securely use crypto.timingSafeEqual. A malicious attacker could estimate the length of one valid bearer token. According to the corresponding RFC 6750, the bearer token has only base64 valid characters, reducing the range of characters for a brute force attack. Version 7.0.2 and 8.0.1 of @fastify/bearer-auth contain a patch. There are currently no known workarounds. The package fastify-bearer-auth, which covers versions 6.0.3 and prior, is also vulnerable starting at version 5.0.1. Users of fastify-bearer-auth should upgrade to a patched version of @fastify/bearer-auth.

Affected products

How to fix

Upgrade to a fixed version: fastify-bearer-auth 7.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-31142 or the next vulnerability affects your stack