What’s Vulnerable › Vulnerabilities
CVE-2022-31143: Leak of sensitive information through login page error in GLPI
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-14 · updated 2026-06-17
- Weakness: CWE-200
Description
GLPI stands for Gestionnaire Libre de Parc Informatique and is a Free Asset and IT Management Software package, that provides ITIL Service Desk features, licenses tracking and software auditing. It was found that in affected versions there is an exposure of private information defined in setup of GLPI (like smtp or cas hosts). Note that passwords are not exposed. Users are advised to upgrade to version 10.0.3. There are no known workarounds for this issue.
Affected products
- glpi-project glpi: before 10.0.3 — fixed in 10.0.3
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/e66a0dfe697cbd4b3ec22736a8f8fd025a28f978
- https://github.com/glpi-project/glpi/security/advisories/GHSA-6mmq-x3j2-677j
- https://github.com/glpi-project/glpi/commit/e66a0dfe697cbd4b3ec22736a8f8fd025a28f978
- https://github.com/glpi-project/glpi/security/advisories/GHSA-6mmq-x3j2-677j
Get alerted when CVE-2022-31143 or the next vulnerability affects your stack