What’s Vulnerable › Vulnerabilities
CVE-2022-31144: Potential heap overflow in Redis
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-19 · updated 2026-06-17
- Weakness: CWE-122
Description
Redis is an in-memory database that persists on disk. A specially crafted `XAUTOCLAIM` command on a stream key in a specific state may result with heap overflow, and potentially remote code execution. This problem affects versions on the 7.x branch prior to 7.0.4. The patch is released in version 7.0.4.
Affected products
- Redis: from 7.0 before 7.0.4 — fixed in 7.0.4
How to fix
Upgrade to a fixed version: Redis 7.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/releases/tag/7.0.4
- https://github.com/redis/redis/security/advisories/GHSA-96f7-42fg-2jrh
- https://security.gentoo.org/glsa/202209-17
- https://security.netapp.com/advisory/ntap-20220909-0002/
- https://github.com/redis/redis/releases/tag/7.0.4
- https://github.com/redis/redis/security/advisories/GHSA-96f7-42fg-2jrh
- https://security.gentoo.org/glsa/202209-17
- https://security.netapp.com/advisory/ntap-20220909-0002/
Get alerted when CVE-2022-31144 or the next vulnerability affects your stack