What’s Vulnerable › Vulnerabilities
CVE-2022-31145: Insufficient AccessToken Expiration Check in FlyteAdmin
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-13 · updated 2026-06-17
- Weakness: CWE-613
Description
FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. In versions 1.1.30 and prior, authenticated users using an external identity provider can continue to use Access Tokens and ID Tokens even after they expire. Users who use FlyteAdmin as the OAuth2 Authorization Server are unaffected by this issue. A patch is available on the `master` branch of the repository. As a workaround, rotating signing keys immediately will invalidate all open sessions and force all users to attempt to obtain new tokens. Those who use this workaround should continue to rotate keys until FlyteAdmin has been upgraded and hide FlyteAdmin deployment ingress URL from the internet.
Affected products
- flyteorg flyteadmin: before 1.1.31 — fixed in 1.1.31
How to fix
Upgrade to a fixed version: flyteorg flyteadmin 1.1.31. Check the vendor advisory for mitigations.
References
- https://github.com/flyteorg/flyteadmin/commit/a1ec282d02706e074bc4986fd0412e5da3b9d00a
- https://github.com/flyteorg/flyteadmin/pull/455
- https://github.com/flyteorg/flyteadmin/security/advisories/GHSA-qwrj-9hmp-gpxh
- https://github.com/flyteorg/flyteadmin/commit/a1ec282d02706e074bc4986fd0412e5da3b9d00a
- https://github.com/flyteorg/flyteadmin/pull/455
- https://github.com/flyteorg/flyteadmin/security/advisories/GHSA-qwrj-9hmp-gpxh
Get alerted when CVE-2022-31145 or the next vulnerability affects your stack