What’s Vulnerable › Vulnerabilities
CVE-2022-31147: jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-14 · updated 2026-06-17
- Weakness: CWE-1333
Description
The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.
Affected products
- jquery-validation: before 1.19.5 — fixed in 1.19.5
How to fix
Upgrade to a fixed version: jquery-validation 1.19.5. Check the vendor advisory for mitigations.
References
- https://github.com/jquery-validation/jquery-validation/commit/5bbd80d27fc6b607d2f7f106c89522051a9fb0dd
- https://github.com/jquery-validation/jquery-validation/releases/tag/1.19.5
- https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-ffmh-x56j-9rc3
- https://github.com/jquery-validation/jquery-validation/commit/5bbd80d27fc6b607d2f7f106c89522051a9fb0dd
- https://github.com/jquery-validation/jquery-validation/releases/tag/1.19.5
- https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-ffmh-x56j-9rc3
Get alerted when CVE-2022-31147 or the next vulnerability affects your stack