What’s Vulnerable › Vulnerabilities
CVE-2022-31148: Persistent cross site scripting in customer module in Shopware
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Shopware is an open source e-commerce software. In versions from 5.7.0 a persistent cross site scripting (XSS) vulnerability exists in the customer module. Users are recommend to update to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.
Affected products
- shopware: from 5.7.0 before 5.7.14 — fixed in 5.7.14
How to fix
Upgrade to a fixed version: shopware 5.7.14. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022
- https://github.com/shopware/shopware/commit/7875855005648fba7b39371a70816afae2e07daf
- https://github.com/shopware/shopware/security/advisories/GHSA-5834-xv5q-cgfw
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022
- https://github.com/shopware/shopware/commit/7875855005648fba7b39371a70816afae2e07daf
- https://github.com/shopware/shopware/security/advisories/GHSA-5834-xv5q-cgfw
Get alerted when CVE-2022-31148 or the next vulnerability affects your stack