What’s Vulnerable › Vulnerabilities
CVE-2022-31157: Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-15 · updated 2026-06-17
- Weakness: CWE-327
Description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Affected products
- packbackbooks lti-1-3-php-library: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: packbackbooks lti-1-3-php-library 5.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-768m-5w34-2xf5
- https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-768m-5w34-2xf5
Get alerted when CVE-2022-31157 or the next vulnerability affects your stack