What’s Vulnerable › Vulnerabilities
CVE-2022-31158: Authentication Bypass by Capture-replay in packbackbooks/lti-1-3-php-library
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-15 · updated 2026-06-17
- Weakness: CWE-294
Description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Affected products
- packbackbooks lti-1-3-php-library: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: packbackbooks lti-1-3-php-library 5.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-5p73-qg2v-383h
- https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-5p73-qg2v-383h
Get alerted when CVE-2022-31158 or the next vulnerability affects your stack