What’s Vulnerable › Vulnerabilities
CVE-2022-31160: jQuery UI contains potential XSS vulnerability when refreshing a checkboxradio with an HTML-like initial text label
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
jQuery UI is a curated set of user interface interactions, effects, widgets, and themes built on top of jQuery. Versions prior to 1.13.2 are potentially vulnerable to cross-site scripting. Initializing a checkboxradio widget on an input enclosed within a label makes that parent label contents considered as the input label. Calling `.checkboxradio( "refresh" )` on such a widget and the initial HTML contained encoded HTML entities will make them erroneously get decoded. This can lead to potentially executing JavaScript code. The bug has been patched in jQuery UI 1.13.2. To remediate the issue, someone who can change the initial HTML can wrap all the non-input contents of the `label` in a `span`.
Affected products
- Debian Linux: 10.0
- Drupal Jquery Ui Checkboxradio: 8.x-1.0, 8.x-1.1, 8.x-1.2, 8.x-1.3
- Fedoraproject Fedora: 35, 36, 37
- Jqueryui Jquery Ui: before 1.13.2 — fixed in 1.13.2
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
- OnCommand Insight: all versions
How to fix
Upgrade to a fixed version: Jqueryui Jquery Ui 1.13.2. Check the vendor advisory for mitigations.
References
- https://blog.jqueryui.com/2022/07/jquery-ui-1-13-2-released/
- https://github.com/jquery/jquery-ui/commit/8cc5bae1caa1fcf96bf5862c5646c787020ba3f9
- https://github.com/jquery/jquery-ui/security/advisories/GHSA-h6gj-6jjq-h8g9
- https://lists.debian.org/debian-lts-announce/2022/12/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6XBR3G3JR5ZIOJDO4224M3INXDS2VFDD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J5LGNTICB5BRFAG3DHVVELS6H3CZSQMO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QB2FJQXCNHO32VGVOC6DY6IPGVE4VDU6/
- https://security.netapp.com/advisory/ntap-20220909-0007/
- https://www.drupal.org/sa-contrib-2022-052
- https://blog.jqueryui.com/2022/07/jquery-ui-1-13-2-released/
- https://github.com/jquery/jquery-ui/commit/8cc5bae1caa1fcf96bf5862c5646c787020ba3f9
- https://github.com/jquery/jquery-ui/security/advisories/GHSA-h6gj-6jjq-h8g9
Get alerted when CVE-2022-31160 or the next vulnerability affects your stack