What’s Vulnerable › Vulnerabilities
CVE-2022-31167: XWiki Platform Security Parent POM vulnerable to overwriting of security rules of a page with a final page having the same reference
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-07 · updated 2026-06-17
- Weakness: CWE-285
Description
XWiki Platform Security Parent POM contains the security APIs for XWiki Platform, a generic wiki platform. Starting with version 5.0 and prior to 12.10.11, 13.10.1, and 13.4.6, a bug in the security cache stores rules associated to document Page1.Page2 and space Page1.Page2 in the same cache entry. That means that it's possible to overwrite the rights of a space or a document by creating the page of the space with the same name and checking the right of the new one first so that they end up in the security cache and are used for the other too. The problem has been patched in XWiki 12.10.11, 13.10.1, and 13.4.6. There are no known workarounds.
Affected products
- xwiki-platform: from 5.0 before 12.10.11; from 13.0 before 13.4.6; from 13.5 before 13.10.1 — fixed in 12.10.11, 13.10.1, 13.4.6
How to fix
Upgrade to a fixed version: xwiki-platform 12.10.11, 13.10.1, 13.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-gg53-wf5x-r3r6
- https://jira.xwiki.org/browse/XWIKI-14075
- https://jira.xwiki.org/browse/XWIKI-18983
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-gg53-wf5x-r3r6
- https://jira.xwiki.org/browse/XWIKI-14075
- https://jira.xwiki.org/browse/XWIKI-18983
Get alerted when CVE-2022-31167 or the next vulnerability affects your stack