What’s Vulnerable › Vulnerabilities
CVE-2022-31168: Zulip Server insufficient authorization for changing bot roles
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-22 · updated 2026-06-17
- Weakness: CWE-285
Description
Zulip is an open source team chat tool. Due to an incorrect authorization check in Zulip Server 5.4 and earlier, a member of an organization could craft an API call that grants organization administrator privileges to one of their bots. The vulnerability is fixed in Zulip Server 5.5. Members who don’t own any bots, and lack permission to create them, can’t exploit the vulnerability. As a workaround for the vulnerability, an organization administrator can restrict the `Who can create bots` permission to administrators only, and change the ownership of existing bots.
Affected products
- zulip: before 5.5 — fixed in 5.5
How to fix
Upgrade to a fixed version: zulip 5.5. Check the vendor advisory for mitigations.
References
- https://github.com/zulip/zulip/commit/751b2a03e565e9eb02ffe923b7c24ac73d604034
- https://github.com/zulip/zulip/releases/tag/5.5
- https://github.com/zulip/zulip/security/advisories/GHSA-c3cp-ggg5-9xw5
- https://github.com/zulip/zulip/commit/751b2a03e565e9eb02ffe923b7c24ac73d604034
- https://github.com/zulip/zulip/releases/tag/5.5
- https://github.com/zulip/zulip/security/advisories/GHSA-c3cp-ggg5-9xw5
Get alerted when CVE-2022-31168 or the next vulnerability affects your stack