What’s Vulnerable › Vulnerabilities
CVE-2022-31170: OpenZeppelin Contracts's ERC165Checker may revert instead of returning false
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-22 · updated 2026-06-17
- Weakness: CWE-20
Description
OpenZeppelin Contracts is a library for smart contract development. Versions 4.0.0 until 4.7.1 are vulnerable to ERC165Checker reverting instead of returning `false`. `ERC165Checker.supportsInterface` is designed to always successfully return a boolean, and under no circumstance revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-165 as expected, specifically if it returns a value other than 0 or 1. The contracts that may be affected are those that use `ERC165Checker` to check for support for an interface and then handle the lack of support in a way other than reverting. The issue was patched in version 4.7.1.
Affected products
- openzeppelin-contracts: from 4.0.0 before 4.7.1 — fixed in 4.7.1
How to fix
Upgrade to a fixed version: openzeppelin-contracts 4.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3552
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-qh9x-gcfh-pcrw
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3552
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-qh9x-gcfh-pcrw
Get alerted when CVE-2022-31170 or the next vulnerability affects your stack