What’s Vulnerable › Vulnerabilities
CVE-2022-31172: OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-22 · updated 2026-06-17
- Weakness: CWE-20
Description
OpenZeppelin Contracts is a library for smart contract development. Versions 4.1.0 until 4.7.1 are vulnerable to the SignatureChecker reverting. `SignatureChecker.isValidSignatureNow` is not expected to revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-1271 as expected. The contracts that may be affected are those that use `SignatureChecker` to check the validity of a signature and handle invalid signatures in a way other than reverting. The issue was patched in version 4.7.1.
Affected products
- openzeppelin-contracts: from 4.1.0 before 4.7.1 — fixed in 4.7.1
How to fix
Upgrade to a fixed version: openzeppelin-contracts 4.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3552
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-4g63-c64m-25w9
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3552
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-4g63-c64m-25w9
Get alerted when CVE-2022-31172 or the next vulnerability affects your stack