What’s Vulnerable › Vulnerabilities
CVE-2022-31173: Juniper is vulnerable to @DOS GraphQL Nested Fragments overflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-400
Description
Juniper is a GraphQL server library for Rust. Affected versions of Juniper are vulnerable to uncontrolled recursion resulting in a program crash. This issue has been addressed in version 0.15.10. Users are advised to upgrade. Users unable to upgrade should limit the recursion depth manually.
Affected products
- graphql-rust juniper: before 0.15.10 — fixed in 0.15.10
How to fix
Upgrade to a fixed version: graphql-rust juniper 0.15.10. Check the vendor advisory for mitigations.
References
- https://github.com/graphql-rust/juniper/blob/juniper-v0.15.10/juniper/CHANGELOG.md#01510-2022-07-28
- https://github.com/graphql-rust/juniper/commit/2b609ee057be950e3454b69fadc431d120e407bb
- https://github.com/graphql-rust/juniper/commit/8d28cdba6eb10f53490ba41d1b5cb40506c2de22
- https://github.com/graphql-rust/juniper/security/advisories/GHSA-4rx6-g5vg-5f3j
- https://github.com/graphql-rust/juniper/blob/juniper-v0.15.10/juniper/CHANGELOG.md#01510-2022-07-28
- https://github.com/graphql-rust/juniper/commit/2b609ee057be950e3454b69fadc431d120e407bb
- https://github.com/graphql-rust/juniper/commit/8d28cdba6eb10f53490ba41d1b5cb40506c2de22
- https://github.com/graphql-rust/juniper/security/advisories/GHSA-4rx6-g5vg-5f3j
Get alerted when CVE-2022-31173 or the next vulnerability affects your stack