What’s Vulnerable › Vulnerabilities
CVE-2022-31182: Cache poisoning via maliciously-formed request in Discourse
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-404
Description
Discourse is the an open source discussion platform. In affected versions a maliciously crafted request for static assets could cause error responses to be cached by Discourse's default NGINX proxy configuration. A corrected NGINX configuration is included in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- discourse: before 2.8.7; 2.9.0-beta7 — fixed in 2.8.7
How to fix
Upgrade to a fixed version: discourse 2.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/7af25544c3940c4d046c51f4cfac9c72a06d4f50
- https://github.com/discourse/discourse/security/advisories/GHSA-4ff8-3j78-w6pp
- https://github.com/discourse/discourse/commit/7af25544c3940c4d046c51f4cfac9c72a06d4f50
- https://github.com/discourse/discourse/security/advisories/GHSA-4ff8-3j78-w6pp
Get alerted when CVE-2022-31182 or the next vulnerability affects your stack