What’s Vulnerable › Vulnerabilities
CVE-2022-31187: Stored Cross Site Scripting (XSS) through global search in GLPI
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-14 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI stands for Gestionnaire Libre de Parc Informatique and is a Free Asset and IT Management Software package, that provides ITIL Service Desk features, licenses tracking and software auditing. Affected versions were found to not properly neutralize HTML tags in the global search context. Users are advised to upgrade to version 10.0.3 to resolve this issue. Users unable to upgrade should disable global search.
Affected products
- glpi-project glpi: before 10.0.3 — fixed in 10.0.3
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/e248ed5649d267c0f61a17d99b7bd6be4074aadb
- https://github.com/glpi-project/glpi/security/advisories/GHSA-43j5-xhvj-9236
- https://github.com/glpi-project/glpi/commit/e248ed5649d267c0f61a17d99b7bd6be4074aadb
- https://github.com/glpi-project/glpi/security/advisories/GHSA-43j5-xhvj-9236
Get alerted when CVE-2022-31187 or the next vulnerability affects your stack