What’s Vulnerable › Vulnerabilities
CVE-2022-3119: OAuth client Single Sign On for WordPress < 3.0.4 - Unauthenticated Settings Update to Authentication Bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-26 · updated 2026-06-17
- Weakness: CWE-287
Description
The OAuth client Single Sign On WordPress plugin before 3.0.4 does not have authorisation and CSRF when updating its settings, which could allow unauthenticated attackers to update them and change the OAuth endpoints to ones they controls, allowing them to then be authenticated as admin if they know the correct email address
Affected products
- OAuth client Single Sign On for WordPress ( OAuth 2.0 SSO ): before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: OAuth client Single Sign On for WordPress ( OAuth 2.0 SSO ) 3.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/55b83cee-a8a5-4f9d-a976-a3eed9a558e5
- https://wpscan.com/vulnerability/55b83cee-a8a5-4f9d-a976-a3eed9a558e5
Get alerted when CVE-2022-3119 or the next vulnerability affects your stack