What’s Vulnerable › Vulnerabilities
CVE-2022-31191: Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
DSpace open source software is a repository application which provides durable access to digital resources. dspace-jspui is a UI component for DSpace. The JSPUI spellcheck "Did you mean" HTML escapes the data-spell attribute in the link, but not the actual displayed text. Similarly, the JSPUI autocomplete HTML does not properly escape text passed to it. Both are vulnerable to XSS. This vulnerability only impacts the JSPUI. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- DSpace: from 4.0 (excl.) through 5.10; from 6.0 (excl.) before 6.4 — fixed in 6.4
How to fix
Upgrade to a fixed version: DSpace 6.4. Check the vendor advisory for mitigations.
References
- https://github.com/DSpace/DSpace/commit/35030a23e48b5946f5853332c797e1c4adea7bb7
- https://github.com/DSpace/DSpace/commit/6f75bb084ab1937d094208c55cd84340040bcbb5
- https://github.com/DSpace/DSpace/commit/c89e493e517b424dea6175caba54e91d3847fc3a
- https://github.com/DSpace/DSpace/commit/ebb83a75234d3de9be129464013e998dc929b68d
- https://github.com/DSpace/DSpace/security/advisories/GHSA-c558-5gfm-p2r8
- https://github.com/DSpace/DSpace/commit/35030a23e48b5946f5853332c797e1c4adea7bb7
- https://github.com/DSpace/DSpace/commit/6f75bb084ab1937d094208c55cd84340040bcbb5
- https://github.com/DSpace/DSpace/commit/c89e493e517b424dea6175caba54e91d3847fc3a
- https://github.com/DSpace/DSpace/commit/ebb83a75234d3de9be129464013e998dc929b68d
- https://github.com/DSpace/DSpace/security/advisories/GHSA-c558-5gfm-p2r8
Get alerted when CVE-2022-31191 or the next vulnerability affects your stack