What’s Vulnerable › Vulnerabilities
CVE-2022-31192: Cross Site Scripting possible in DSpace JSPUI "Request a Copy" feature
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
DSpace open source software is a repository application which provides durable access to digital resources. dspace-jspui is a UI component for DSpace. The JSPUI "Request a Copy" feature does not properly escape values submitted and stored from the "Request a Copy" form. This means that item requests could be vulnerable to XSS attacks. This vulnerability only impacts the JSPUI. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- DSpace: from 4.0 through 5.10; from 6.0 (excl.) before 6.4 — fixed in 6.4
How to fix
Upgrade to a fixed version: DSpace 6.4. Check the vendor advisory for mitigations.
References
- https://github.com/DSpace/DSpace/commit/28eb8158210d41168a62ed5f9e044f754513bc37
- https://github.com/DSpace/DSpace/commit/f7758457b7ec3489d525e39aa753cc70809d9ad9
- https://github.com/DSpace/DSpace/security/advisories/GHSA-4wm8-c2vv-xrpq
- https://github.com/DSpace/DSpace/commit/28eb8158210d41168a62ed5f9e044f754513bc37
- https://github.com/DSpace/DSpace/commit/f7758457b7ec3489d525e39aa753cc70809d9ad9
- https://github.com/DSpace/DSpace/security/advisories/GHSA-4wm8-c2vv-xrpq
Get alerted when CVE-2022-31192 or the next vulnerability affects your stack