What’s Vulnerable › Vulnerabilities
CVE-2022-31198: GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-682
Description
OpenZeppelin Contracts is a library for secure smart contract development. This issue concerns instances of Governor that use the module `GovernorVotesQuorumFraction`, a mechanism that determines quorum requirements as a percentage of the voting token's total supply. In affected instances, when a proposal is passed to lower the quorum requirements, past proposals may become executable if they had been defeated only due to lack of quorum, and the number of votes it received meets the new quorum requirement. Analysis of instances on chain found only one proposal that met this condition, and we are actively monitoring for new occurrences of this particular issue. This issue has been patched in v4.7.2. Users are advised to upgrade. Users unable to upgrade should consider avoiding lowering quorum requirements if a past proposal was defeated for lack of quorum.
Affected products
- openzeppelin-contracts: from 4.3.0 before 4.7.2 — fixed in 4.7.2
- OpenZeppelin Contracts Upgradeable: from 4.3.0 before 4.7.2 — fixed in 4.7.2
How to fix
Upgrade to a fixed version: openzeppelin-contracts 4.7.2; OpenZeppelin Contracts Upgradeable 4.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3561
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-xrc4-737v-9q75
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3561
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-xrc4-737v-9q75
Get alerted when CVE-2022-31198 or the next vulnerability affects your stack