What’s Vulnerable › Vulnerabilities
CVE-2022-31228
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-12 · updated 2026-06-17
- Weakness: CWE-307
Description
Dell EMC XtremIO versions prior to X2 6.4.0-22 contain a bruteforce vulnerability. A remote unauthenticated attacker can potentially exploit this vulnerability and gain access to an admin account.
Affected products
- Dell XtremIO: before 6.4.0-22 — fixed in 6.4.0-22
How to fix
Upgrade to a fixed version: Dell XtremIO 6.4.0-22. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000204112/dsa-2022-145-dell-emc-xtremeio-for-ssh-and-web-ui-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000204112/dsa-2022-145-dell-emc-xtremeio-for-ssh-and-web-ui-vulnerability
Get alerted when CVE-2022-31228 or the next vulnerability affects your stack