What’s Vulnerable › Vulnerabilities
CVE-2022-31231
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-22 · updated 2026-07-23
- Weakness: CWE-284
Description
Dell ECS, versions 3.5 and 3.6, contain an Improper Access Control in the Identity and Access Management (IAM) module. A remote unauthenticated attacker may potentially exploit this vulnerability, leading to gaining read access to unauthorized data.
Affected products
- EMC Elastic Cloud Storage all versions prior to 3.1: before 3.5.1.7; from 3.6.0.0 before 3.6.2.4 — fixed in 3.5.1.7, 3.6.2.4
How to fix
Upgrade to a fixed version: EMC Elastic Cloud Storage all versions prior to 3.1 3.5.1.7, 3.6.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-31231 or the next vulnerability affects your stack