What’s Vulnerable › Vulnerabilities
CVE-2022-31234
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-21 · updated 2026-06-17
- Weakness: CWE-307
Description
Dell EMC PowerStore, contain(s) an Improper Restriction of Excessive Authentication Attempts Vulnerability in PowerStore Manager GUI. A remote unauthenticated attacker could potentially exploit this vulnerability, leading to password brute-forcing. Account takeover is possible if weak passwords are used by users.
Affected products
- Dell Emc Powerstore 1200T Firmware: before 3.0.0.0-1732745 — fixed in 3.0.0.0-1732745
- Dell Emc Powerstore 3200T Firmware: before 3.0.0.0-1732745 — fixed in 3.0.0.0-1732745
- Dell Emc Powerstore 500T Firmware: before 3.0.0.0-1732745 — fixed in 3.0.0.0-1732745
- Dell Emc Powerstore 5200T Firmware: before 3.0.0.0-1732745 — fixed in 3.0.0.0-1732745
- Dell Emc Powerstore 9200T Firmware: before 3.0.0.0-1732745 — fixed in 3.0.0.0-1732745
How to fix
Upgrade to a fixed version: Dell Emc Powerstore 1200T Firmware 3.0.0.0-1732745; Dell Emc Powerstore 3200T Firmware 3.0.0.0-1732745; Dell Emc Powerstore 500T Firmware 3.0.0.0-1732745; Dell Emc Powerstore 5200T Firmware 3.0.0.0-1732745; Dell Emc Powerstore 9200T Firmware 3.0.0.0-1732745. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-31234 or the next vulnerability affects your stack