What’s Vulnerable › Vulnerabilities
CVE-2022-31246
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-17 · updated 2026-06-17
- Weakness: CWE-88
Description
paymentrequest.py in Electrum before 4.2.2 allows a file:// URL in the r parameter of a payment request (e.g., within QR code data). On Windows, this can lead to capture of credentials over SMB. On Linux and UNIX, it can lead to a denial of service by specifying the /dev/zero filename.
Affected products
- Electrum: before 4.2.2 — fixed in 4.2.2
How to fix
Upgrade to a fixed version: Electrum 4.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/spesmilo/electrum/security/advisories/GHSA-4fh4-hx35-r355
- https://twitter.com/ElectrumWallet/status/1534540879905665028
- https://github.com/spesmilo/electrum/security/advisories/GHSA-4fh4-hx35-r355
- https://twitter.com/ElectrumWallet/status/1534540879905665028
Get alerted when CVE-2022-31246 or the next vulnerability affects your stack