What’s Vulnerable › Vulnerabilities
CVE-2022-31250: keylime %post scriplet allows for privilege escalation from keylime user to root
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-20 · updated 2026-06-17
- Weakness: CWE-59
Description
A UNIX Symbolic Link (Symlink) Following vulnerability in keylime of openSUSE Tumbleweed allows local attackers to escalate from the keylime user to root. This issue affects: openSUSE Tumbleweed keylime versions prior to 6.4.2-1.1.
Affected products
- openSUSE Tumbleweed: before 6.4.2-1.1 — fixed in 6.4.2-1.1
How to fix
Upgrade to a fixed version: openSUSE Tumbleweed 6.4.2-1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-31250 or the next vulnerability affects your stack