What’s Vulnerable › Vulnerabilities
CVE-2022-31254: rmt-server-pubcloud allows to escalate from user _rmt to root
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-07 · updated 2026-06-17
- Weakness: CWE-276
Description
A Incorrect Default Permissions vulnerability in rmt-server-regsharing service of SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise Server for SAP 15-SP1, SUSE Manager Server 4.1; openSUSE Leap 15.3, openSUSE Leap 15.4 allows local attackers with access to the _rmt user to escalate to root. This issue affects: SUSE Linux Enterprise Server for SAP 15 rmt-server versions prior to 2.10. SUSE Linux Enterprise Server for SAP 15-SP1 rmt-server versions prior to 2.10. SUSE Manager Server 4.1 rmt-server versions prior to 2.10. openSUSE Leap 15.3 rmt-server versions prior to 2.10. openSUSE Leap 15.4 rmt-server versions prior to 2.10.
Affected products
- openSUSE Rmt-Server: before 2.10 — fixed in 2.10
How to fix
Upgrade to a fixed version: openSUSE Rmt-Server 2.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-31254 or the next vulnerability affects your stack