What’s Vulnerable › Vulnerabilities
CVE-2022-31256: sendmail: mail to root privilege escalation via sm-client.pre script
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-26 · updated 2026-06-17
- Weakness: CWE-59
Description
A Improper Link Resolution Before File Access ('Link Following') vulnerability in a script called by the sendmail systemd service of openSUSE Factory allows local attackers to escalate from user mail to root. This issue affects: SUSE openSUSE Factory sendmail versions prior to 8.17.1-1.1.
Affected products
- openSUSE Factory: before 8.17.1-1.1 — fixed in 8.17.1-1.1
How to fix
Upgrade to a fixed version: openSUSE Factory 8.17.1-1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-31256 or the next vulnerability affects your stack