What’s Vulnerable › Vulnerabilities
CVE-2022-31257
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-12 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability has been identified in Mendix Applications using Mendix 7 (All versions < V7.23.31), Mendix Applications using Mendix 8 (All versions < V8.18.18), Mendix Applications using Mendix 9 (All versions < V9.14.0), Mendix Applications using Mendix 9 (V9.12) (All versions < V9.12.2), Mendix Applications using Mendix 9 (V9.6) (All versions < V9.6.12). In case of access to an active user session in an application that is built with an affected version, it’s possible to change that user’s password bypassing password validations within a Mendix application. This could allow to set weak passwords.
Affected products
- Siemens Mendix Applications using Mendix 7: from 7.0.0 before 7.32.31; from 8.0.0 before 8.18.18; from 9.6.0 before 9.6.12; from 9.12.0 before 9.12.2; from 9.13.0 before 9.14.0 — fixed in 7.32.31, 8.18.18, 9.12.2, 9.14.0, 9.6.12
How to fix
Upgrade to a fixed version: Siemens Mendix Applications using Mendix 7 7.32.31, 8.18.18, 9.12.2, 9.14.0. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-433782.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-433782.pdf
Get alerted when CVE-2022-31257 or the next vulnerability affects your stack