What’s Vulnerable › Vulnerabilities
CVE-2022-3127: Cross-site Scripting (XSS) - Stored in jgraph/drawio
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository jgraph/drawio prior to 20.2.8.
Affected products
- jgraph/drawio: before 20.2.8 — fixed in 20.2.8
How to fix
Upgrade to a fixed version: jgraph/drawio 20.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/jgraph/drawio/commit/59887e45b36f06c8dd4919a32bacd994d9f084da
- https://huntr.dev/bounties/6cea89d1-39dc-4023-82fa-821f566b841a
- https://github.com/jgraph/drawio/commit/59887e45b36f06c8dd4919a32bacd994d9f084da
- https://huntr.dev/bounties/6cea89d1-39dc-4023-82fa-821f566b841a
Get alerted when CVE-2022-3127 or the next vulnerability affects your stack