What’s Vulnerable › Vulnerabilities
CVE-2022-31322
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-13 · updated 2026-06-17
- Weakness: CWE-798
Description
Penta Security Systems Inc WAPPLES v6.0 r3 4.10-hotfix1 allows attackers to escalate privileges via overwriting files using SUID flagged executables.
Affected products
- Pentasecurity Wapples: from 5.0.12.0 before 6.0.r3.4.10; v6.0.r3.4.10, v6.0.r3.4.10-hotfix1 — fixed in 6.0.r3.4.10
How to fix
Upgrade to a fixed version: Pentasecurity Wapples 6.0.r3.4.10. Check the vendor advisory for mitigations.
References
- https://medium.com/%40_sadshade/wapples-web-application-firewall-multiple-vulnerabilities-35bdee52c8fb
- https://www.pentasecurity.com/product/wapples/
- https://medium.com/%40_sadshade/wapples-web-application-firewall-multiple-vulnerabilities-35bdee52c8fb
- https://www.pentasecurity.com/product/wapples/
Get alerted when CVE-2022-31322 or the next vulnerability affects your stack